Web Auction 0.3 Released

News about Xataface

Web Auction 0.3 Released

Postby shannah » Fri May 02, 2008 7:51 pm

A new version of web auction has been released at last which corrects a number of issues and adds a few new features.

New features include:
- User-friendly icons for menu items.
- Comes bundled with all dependencies so no need to download dataface separately anymore.
- Timezone support
- Add custom headers and footers through the web based control panel.

Download from Sourceforge
shannah
 
Posts: 4457
Joined: Wed Dec 31, 1969 5:00 pm

Postby rlparker » Fri May 02, 2008 10:48 pm

Congratulations on the new release, Steve! It's great to see Xataface and the Web Auction application continue to grow and mature, and I'm impressed with what I see!

That said, are you sure there is not a packing problem in the webauction-0.3.tar.gz tarball? Now, I'll be the first to admit I may be "borking:" this all by myself, but this is what I encounter when trying to unpack the tarball (using my typical command for unpacking tar.gz files):
Code: Select all
$ tar -zxvf webauction-0.3.tar.gz
webauction-0.3/
webauction-0.3/actions/
webauction-0.3/actions/bid.php
tar: Skipping to next header
tar: Archive contains obsolescent base-64 headers

gzip: stdin: invalid compressed data--format violated
tar: Child returned status 1
tar: Error exit delayed from previous errors


Then again, maybe I'm just "doing it wrong" :?:

Edited to provide more info:
After a bit of googling, I still can't unpack/unzip the tarball, but I think I have some clue as to what the problem *might* be (of course, I could also be completely wrong!).
Code: Select all
$ file webauction-0.3.tar.gz
webauction-0.3.tar.gz: gzip compressed data, was "webauction-0.3.tar", from Unix
Makes me think the tarball itself is ok, and that *seems* to be indicated by the partial successful extraction I experienced. The most common explanation for what I'm seeing, according to google results fro the error message(s) encountered is that the tarball itself might have been uploaded in ASCII vs Binary mode.

I'm not familiar enough with SourceForge operation to know whether or not that could be an issue; just sharing what I learned in case it "rings a bell" with anyone.

Any help on how to extract the contents of the tarball are most appreciated.

Regards,

--rlparker
rlparker
 
Posts: 2
Joined: Fri May 02, 2008 10:31 pm

Postby shannah » Sat May 03, 2008 9:22 am

Hmm... used a different FTP client than usual to upload it. You appear to be correct on the ASCII thing. Unfortunately sourceforge now seems to be down for uploading files. Here is a link to the archive off my server:
http://dev.weblite.ca/webauction-0.3.tar.gz
shannah
 
Posts: 4457
Joined: Wed Dec 31, 1969 5:00 pm

Resolved!

Postby rlparker » Sat May 03, 2008 1:56 pm

Thanks, Steve! Whatever the problem was, you have fixed it as I can unpack the http://dev.weblite.ca/webauction-0.3.tar.gz file with no problem.

Thanks!

Robert
rlparker
 
Posts: 2
Joined: Fri May 02, 2008 10:31 pm


Return to Xataface News

Who is online

Users browsing this forum: Bing [Bot] and 1 guest

cron
Powered by Dataface
© 2005-2007 Steve Hannah All rights reserved