Problems on self hosted site.

A place to discuss and receive support for the Web Auction application.

Problems on self hosted site.

Postby bluebedouin » Tue Aug 16, 2011 1:45 pm

First of all I'd like to say thanks for the webauction script,it was just what I was looking for.When I first came across it I found it on another site with just the download of the files.I uploaded to a free site(freei[dot]me) that offered the stated requirements (PHP 4.3 or higher,MySQL 4.1 or higher).This site also offered a free domain name (bedfordcfparts[dot]cz[dot]cc)which I then had pointed to the free site(bluebedouin[dot]freei[dot]me).After the files were uploaded I logged on to the freei[dot]me site to change the admin password & was immediately locked out.(Your user account has been suspended)When I go to the pointed domain though I can access the page but only partially.I still have access to the cpanel & therefore the files.
I then did a search & found this site with the two links so I started another one on your hosting (auctions[dot]weblite[dot]ca/bedfordcfparts)
Comparing the two,my hosting has links missing compared to yours.
my ownhosted auction.jpg
my ownhosted auction.jpg (16.49 KiB) Viewed 5242 times
my hosted auction.jpg
my hosted auction.jpg (24.01 KiB) Viewed 5242 times

I'm a total novice as far as scripting is concerned so any help would be much appreciated.If you need the password to access my hosting site to examine the files I'm quite happy to supply it.
bluebedouin
 
Posts: 8
Joined: Tue Aug 16, 2011 1:12 pm

Re: Problems on self hosted site.

Postby bluebedouin » Fri Aug 19, 2011 2:13 am

Anybody?
bluebedouin
 
Posts: 8
Joined: Tue Aug 16, 2011 1:12 pm

Re: Problems on self hosted site.

Postby shannah » Mon Aug 22, 2011 2:20 pm

The menu only appears when you are logged in as the admin of the auction. Likely on your auction site you weren't logged in as the admin. I believe the default login for the admin is:
username: admin
password: password

-Steve
shannah
 
Posts: 4457
Joined: Wed Dec 31, 1969 5:00 pm

Re: Problems on self hosted site.

Postby bluebedouin » Tue Aug 23, 2011 2:40 pm

Hi,thanks for the reply.I've just tried again & get the same problem.Definitely logged in.

Viewing the page logged out shows no products too.
bluebedouin
 
Posts: 8
Joined: Tue Aug 16, 2011 1:12 pm

Re: Problems on self hosted site.

Postby shannah » Tue Aug 23, 2011 3:39 pm

Just took a look at your site and found a number of problems:

1. Your .ini files are being served. You need to block this from happening. If your server is running IIS, then you'll need to add a Web.config file (see viewtopic.php?f=5&t=6230).
This is extremely important as I was able to see your conf.ini file with all of your database connection info.

2. You don't appear to have a templates directory. And when I poked around at your templates_c directory it seemed to have the contents that are supposed to be found in the templates directory. Did you rename the templates directory to templates_c? templates_c is meant to be a cache directory for compiled templates only. If you create it you should be creating it empty and writable by the web server.

-Steve
shannah
 
Posts: 4457
Joined: Wed Dec 31, 1969 5:00 pm

Re: Problems on self hosted site.

Postby bluebedouin » Sun Sep 18, 2011 11:22 am

Thanks for the info regarding the .ini file.I did go in & delete the files as I wasn't really sure what else to do.
I've since found out that both those free sites have now gone anyway.Glad I didn't invest too much time on them
. :roll:
bluebedouin
 
Posts: 8
Joined: Tue Aug 16, 2011 1:12 pm


Return to Web Auction Discussion

Who is online

Users browsing this forum: No registered users and 1 guest

cron
Powered by Dataface
© 2005-2007 Steve Hannah All rights reserved