Pear Error in Insertion in Related table

A place for users and developers of the Xataface to discuss and receive support.

Pear Error in Insertion in Related table

Postby muzafar » Thu Feb 28, 2013 11:04 am

Dear Shannah,

I have a related table which I have already mentioned here (viewtopic.php?f=4&t=7141). I have almost 30 fields in this related table, which include upload file and comments fields, for instance, we have fields like below. the fields are more than 30. As i mentioned in the previous post, that i am using fieldgroup__template for it, and the save button is now coming at the button, as u mentioned the solution in that post. Now the problem is, that while inserting a records, it throws the following error.

[Thu Feb 28 19:55:43 2013] [error] [client 192.168.2.1] PHP Fatal
error: Uncaught exception 'Exception' with message '[pear_error:
message="11" code=0 mode=return level=notice prefix="" info="Error performing query 'INSERT INTO `Asses`
(`lComment`,`cComment`,`oComment`,`aComment`,`psComment`,`chartComment`,`generalComment`,`banionComment`,`paseComment`,`authosComment`,`antsComment`,`regateComment`,`mBODComment`,`alRComment`,`oflComment`,`cvvRemarks`,`strRemarks`,`aRemarks`,`mRemarks`,`avaRemarks`,`slsRemarks`,`agmRemarks`,`pnRemarks`)
VALUES (''sdfsdfsdfsdfsdfsfsdfsdfsfsdfsddfasdfsdafdsfsdafjsdkfhdskjfhsdkjafhsdkajfhdsauiwehruewhriewuhewiuhewewurhewurheks in /var/www/xata/Dataface/IO.php on line 1317, referer:




`lUpload` varchar(255) DEFAULT NULL,
`lComment` varchar(1500) NOT NULL DEFAULT 'Not Applicable',
`cUpload` varchar(255) DEFAULT NULL,
`cComment` varchar(1500) NOT NULL DEFAULT 'Not Applicable',
`oUpload` varchar(255) DEFAULT NULL,
`oComment` varchar(1500) NOT NULL DEFAULT 'Not Applicable',


2- I have also tried the fieldgroup tabs in order to show the fields in tabs, but same in related table, for the role Applicant, the Button along with Save, which is "NEXT", doesn't show in the related table.

Kindly lead me.

Thanks,
muzafar
 
Posts: 44
Joined: Mon Nov 28, 2011 9:25 pm

Re: Pear Error in Insertion in Related table

Postby sim » Thu Feb 28, 2013 8:39 pm

Issue resolved unrelated to Xatafce.
Changing the storage engine from inodb to myisam fixed the issue.
sim
 
Posts: 12
Joined: Fri Dec 02, 2011 2:35 am


Return to Xataface Users

Who is online

Users browsing this forum: Google [Bot] and 2 guests

Powered by Dataface
© 2005-2007 Steve Hannah All rights reserved