FCKeditor and Firefox 17

A place for users and developers of the Xataface to discuss and receive support.

FCKeditor and Firefox 17

Postby aytonk » Wed Nov 28, 2012 11:18 am

The FCKeditor html editor has stopped working with Firefox 17. The user agent field in the browser now comes back with "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:17.0) Gecko/17.0 Firefox/17.0" (or similar). In previous versions the text after "Gecko" was of the form 20100101.

I've found two places where this is tested - /Xataface/lib/FCKeditor/fckeditor.php (line 49) and /Xataface/lib/FCKeditor/fckeditor.js (line 287). I've patched the return to be true in each of these places, but it's still not working. I've even tried restarting the browser and rebooting the webserver in case anything was being cached.

Is there a third place I need to modify?

OK, I'll be dropping FCKeditor once I move to v2.0 of Xataface, but that may not be for a little while, and I can't lose this functionality - and I don't have control over my clients' browser versions.

All help appreciated.

Thanks

Kevin
aytonk
 
Posts: 7
Joined: Wed Apr 25, 2012 10:36 am

Re: FCKeditor and Firefox 17

Postby shannah » Fri Nov 30, 2012 4:50 am

This looks like this problem.
http://support.mozilla.org/en-US/questions/942438

A fix is suggested there - but it sounds like a bug in Firefox that will be fixed in future updates.
--
Steve Hannah
@shannah78 (on twitter)
sjhannah.com blog
shannah
 
Posts: 4457
Joined: Wed Dec 31, 1969 5:00 pm


Return to Xataface Users

Who is online

Users browsing this forum: No registered users and 3 guests

cron
Powered by Dataface
© 2005-2007 Steve Hannah All rights reserved