Checkbox field in Grid

A place for users and developers of the Xataface to discuss and receive support.

Checkbox field in Grid

Postby casanovax7 » Mon Nov 26, 2012 10:16 am

I have a grid widget pulling data from a related table, and everything seems to work fine, except for selections made using the related checkbox widget do not appear (though they save just fine).

To clarify: Table A pulls data from Table B into a Grid widget. Table B has a field that uses the checkbox widget (let's call this Table B:Field 1). When editing records in Table A, the Grid widget appears to work just fine, and shows all the appropriate valuelist options for Table B:Field 1, but when selections are made and the record is saved, those selections do not show up in Table A's Grid widget as "checked". Viewing the record in Table B directly shows that the data is, in fact, saved correctly (all selections appear checked as they should).

Is this expected? Any others with the same issue solve this? Other thoughts?
casanovax7
 
Posts: 20
Joined: Wed Sep 05, 2012 3:36 pm

Re: Checkbox field in Grid

Postby shannah » Fri Nov 30, 2012 4:18 am

What version of Xataface are you using? Can you post a minimal test case that I can easily try? E.g. table defs, fields.ini, relationships.ini ...

-Steve
--
Steve Hannah
@shannah78 (on twitter)
sjhannah.com blog
shannah
 
Posts: 4457
Joined: Wed Dec 31, 1969 5:00 pm


Return to Xataface Users

Who is online

Users browsing this forum: No registered users and 3 guests

Powered by Dataface
© 2005-2007 Steve Hannah All rights reserved