Xataface2.0 widget:type = date

A place for users and developers of the Xataface to discuss and receive support.

Xataface2.0 widget:type = date

Postby mstegani » Tue Nov 06, 2012 3:59 pm

I've upgrade to Xataface2.0 alpha1 but I've a problem with widget:type = date, return a void page.
Using Xataface 1.32 I've no problem.

Can help me?
thanks
Marco
mstegani
 
Posts: 9
Joined: Mon Sep 24, 2012 2:24 am

Re: Xataface2.0 widget:type = date

Postby shannah » Wed Nov 07, 2012 8:48 am

Thanks for reporting this. I haven't used the date widget in ages.. this must be a bug. I have added it to the issue tracker here:
http://bugs.weblite.ca/view.php?id=1169

Does your error log report any errors?
--
Steve Hannah
@shannah78 (on twitter)
sjhannah.com blog
shannah
 
Posts: 4457
Joined: Wed Dec 31, 1969 5:00 pm

Re: Xataface2.0 widget:type = date

Postby mstegani » Fri Nov 09, 2012 10:43 am

I set in index.php error_reporting(E_ALL); but I see only a void page, no error
mstegani
 
Posts: 9
Joined: Mon Sep 24, 2012 2:24 am

Re: Xataface2.0 widget:type = date

Postby shannah » Fri Nov 09, 2012 11:00 am

try
Code: Select all
ini_set('display_errors', 'on');


Alternatively, find out where your error log is.
--
Steve Hannah
@shannah78 (on twitter)
sjhannah.com blog
shannah
 
Posts: 4457
Joined: Wed Dec 31, 1969 5:00 pm

Re: Xataface2.0 widget:type = date

Postby mstegani » Sat Nov 10, 2012 7:29 am

this is the error:
"Parse error: parse error, expecting `')'' in /Users/marcostegani/Sites/xataface2_0alpha1/lib/HTML/QuickForm/date.php on line 77"

if I change date.php on line 77
'maxYear' => intval(date('Y'))+5,
with
'maxYear' => 2015,
it work fine
mstegani
 
Posts: 9
Joined: Mon Sep 24, 2012 2:24 am

Re: Xataface2.0 widget:type = date

Postby shannah » Sat Nov 10, 2012 1:46 pm

That is strange. That code should work fine. It makes me think there might be something corrupted in the file.
--
Steve Hannah
@shannah78 (on twitter)
sjhannah.com blog
shannah
 
Posts: 4457
Joined: Wed Dec 31, 1969 5:00 pm

Re: Xataface2.0 widget:type = date

Postby mstegani » Sun Nov 11, 2012 11:56 pm

I have the same problem with version 1.9 and now with 2.0alpha. I tried 2.0 with widget data just downloaded.
mstegani
 
Posts: 9
Joined: Mon Sep 24, 2012 2:24 am

Re: Xataface2.0 widget:type = date

Postby mstegani » Mon Nov 12, 2012 1:55 am

Also with version 1.3.3 but not with 1.3.2
mstegani
 
Posts: 9
Joined: Mon Sep 24, 2012 2:24 am

Re: Xataface2.0 widget:type = date

Postby shannah » Tue Nov 13, 2012 9:43 am

I have added this to the issue tracker.
http://bugs.weblite.ca/view.php?id=1174
--
Steve Hannah
@shannah78 (on twitter)
sjhannah.com blog
shannah
 
Posts: 4457
Joined: Wed Dec 31, 1969 5:00 pm

Re: Xataface2.0 widget:type = date

Postby Cabeza » Sun Mar 03, 2013 4:53 am

Steve,
Hi.. long time, no see :-)
Is this actually resolved? in which version? what was the fix?

I am running 2.0alpha1 and it bonks on line 77 of date.php (class HTML_QuickForm_date)
Code: Select all
...
'maxYear' => intval(date('Y'))+5,
...

But I guess you already know that.
Is there a v2.0alpha2? where to get it?
Thanks

Xataface version: 2alpha1 on Ubuntu Server 12.04 nginx 1.3.12 php 5.3.10 MariaDB 5.5.29
Cabeza
 
Posts: 31
Joined: Mon Sep 03, 2012 10:25 am

Re: Xataface2.0 widget:type = date

Postby shannah » Mon Mar 04, 2013 11:03 am

It is fixed in SVN rev 4180 (in the 2.0.x branch). I haven't pushed this out into a release yet. A good way to keep up to date would be to work directly off of the 2.0.x SVN branch.

-Steve
--
Steve Hannah
@shannah78 (on twitter)
sjhannah.com blog
shannah
 
Posts: 4457
Joined: Wed Dec 31, 1969 5:00 pm

Re: Xataface2.0 widget:type = date

Postby Cabeza » Mon Mar 04, 2013 1:11 pm

Steve,
Thanks. I need a bit of handholding here (well what's new? :) ). I am more of a git user, SVN not my cup of tea.
I have checked out revision 4361 from http://weblite.ca/svn/dataface/core/branches/2.0.x Is this the one you are referring to?
I see that date.php on QuickForm is fixed via HTML_QUICKFORM_DATE_MAXYEAR, so this is probably the right one.
Version.txt still lists 1.9 3856... but I am guessing this is not relevant.
Let me know.

Xataface version: 2alpha1 on Ubuntu Server 12.04 nginx 1.3.12 php 5.3.10 MariaDB 5.5.29
Cabeza
 
Posts: 31
Joined: Mon Sep 03, 2012 10:25 am

Re: Xataface2.0 widget:type = date

Postby shannah » Mon Mar 04, 2013 2:14 pm

I have updated the version.txt to show 2.0-alpha2 now. If you do an SVN update it should reflect this.
You are using the correct version.

Steve
--
Steve Hannah
@shannah78 (on twitter)
sjhannah.com blog
shannah
 
Posts: 4457
Joined: Wed Dec 31, 1969 5:00 pm

Re: Xataface2.0 widget:type = date

Postby Cabeza » Tue Mar 05, 2013 1:44 am

Steve,
Further on this if I may, the SVN branch version is significantly fatter than the original alpha I had. This is clearly due to the fact that the thing is not packaged for release. Can you tell me what can be safely discarded without affecting functionality? I did a comparison and got rid of the stuff that is most obviously only relevant to your development workflow, etc., but I would feel more confident if you gave me some pointers.
Thanks again.

Xataface version: 2alpha1 on Ubuntu Server 12.04 nginx 1.3.12 php 5.3.10 MariaDB 5.5.29
Cabeza
 
Posts: 31
Joined: Mon Sep 03, 2012 10:25 am

Re: Xataface2.0 widget:type = date

Postby shannah » Tue Mar 05, 2013 9:59 am

Check the build.xml file to see which directories and files can be deleted. A big one is the tests directory.
--
Steve Hannah
@shannah78 (on twitter)
sjhannah.com blog
shannah
 
Posts: 4457
Joined: Wed Dec 31, 1969 5:00 pm


Return to Xataface Users

Who is online

Users browsing this forum: Exabot [Bot] and 1 guest

cron
Powered by Dataface
© 2005-2007 Steve Hannah All rights reserved