Page 2 of 2

PostPosted: Thu Nov 16, 2006 6:38 am
by njw
Looking through the code, that would appear to be a problem loading the page references into the PAGES array - is this also a global variable? And if so, how do I change the code to make it global?


PostPosted: Thu Nov 16, 2006 5:06 pm
by shannah
Wow.. you're going at it hard here....

First: I keep register globals off on all of my servers for security reasons. Dataface will work fine with this setting.

I'd be a little wary before changing too many of the variables in the template. The $ENV shoud be $ENV and not $_ENV, for example.

It is painful thinking of the pain you must be going through trying to get this working, but my best advice, before taking the hatchet to your site any further, might be to try installing the default version of LCMS on the new server and see if it has the same problems. If it does, then we can try hatcheting that (rather than taking your whole site apart). Certainly the problem is just one simple setting on the server's end, or in the configuration.

One thing to try also, is try entering the explicit address to the page. e.g. instead of .... it could be a problem with not picking up the page name properly and getting null page....


PostPosted: Thu Nov 16, 2006 5:46 pm
by njw
On the $ENV, it works when I change them to $_ENV ... There weren't that many of them - only in the one script.

I have tried entering explicit addresses e.g. and that errors. gives the same result as

All my Dataface applications are working fine; this only affects LCMS. Even admin.php works for the LCMS site!

The menu tabs are not displaying - and the code would suggest that that means the pages array is not being filled.

I'll have a look at reloading LCMS onto the new site, but it is now live because I had to change the nameservers to test because of the addressing problems with the scripts - or so I thought at the time!

Happy days.


PostPosted: Fri Nov 17, 2006 10:38 am
by njw
Ok Steve, I reset styles.css and MainTemplate.html from the original source. The site displayed all the text but wothout any formatting, so I made the following changes to MainTemplate.html:

* Changed all references to $ENV to $_ENV. This got the styles .css working, but lost the horizontal menu and the logo.
* Added reference to archomai_style.css This got the widths almost correct, but that's probably due to me not editing the correct file originally.
* Changed $_ENV back to $ENV for horizontal menu section. Started working.
* Changed $_ENV back to $ENV for logo section. Started working.
* "Sites" section not working - commented out. This displays fine, but errors with call to invalid module, or something similar, when clicked.

So, on the plus side, I have a working site - many thanks for reminding me of first principles!

On the downside, I still don't understand what has caused the problem!

Any further thoughts?