[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/functions.php on line 4586: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3765)
[phpBB Debug] PHP Warning: in file /includes/functions.php on line 4588: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3765)
[phpBB Debug] PHP Warning: in file /includes/functions.php on line 4589: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3765)
[phpBB Debug] PHP Warning: in file /includes/functions.php on line 4590: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3765)
Xataface Forums • View topic - Error when moving site

Error when moving site

A place to discuss and receive support for LCMS (Little Content Management System)

Postby njw » Thu Nov 16, 2006 6:38 am

Looking through the code, that would appear to be a problem loading the page references into the PAGES array - is this also a global variable? And if so, how do I change the code to make it global?

Neil
njw
 
Posts: 280
Joined: Wed Dec 31, 1969 5:00 pm

Postby shannah » Thu Nov 16, 2006 5:06 pm

Wow.. you're going at it hard here....

First: I keep register globals off on all of my servers for security reasons. Dataface will work fine with this setting.

I'd be a little wary before changing too many of the variables in the template. The $ENV shoud be $ENV and not $_ENV, for example.

It is painful thinking of the pain you must be going through trying to get this working, but my best advice, before taking the hatchet to your site any further, might be to try installing the default version of LCMS on the new server and see if it has the same problems. If it does, then we can try hatcheting that (rather than taking your whole site apart). Certainly the problem is just one simple setting on the server's end, or in the configuration.

One thing to try also, is try entering the explicit address to the page. e.g. http://www.archomai.co.uk/index.php instead of http://www.archomai.co.uk .... it could be a problem with not picking up the page name properly and getting null page....

-Steve
--
Steve Hannah
(on twitter)
shannah
 
Posts: 4457
Joined: Wed Dec 31, 1969 5:00 pm

Postby njw » Thu Nov 16, 2006 5:46 pm

On the $ENV, it works when I change them to $_ENV ... There weren't that many of them - only in the one script.

I have tried entering explicit addresses e.g. www.archomai.co.uk/about.php and that errors. www.archomai.co.uk/index.php gives the same result as www.archomai.co.uk

All my Dataface applications are working fine; this only affects LCMS. Even admin.php works for the LCMS site!

The menu tabs are not displaying - and the code would suggest that that means the pages array is not being filled.

I'll have a look at reloading LCMS onto the new site, but it is now live because I had to change the nameservers to test because of the addressing problems with the scripts - or so I thought at the time!

Happy days.

Neil
njw
 
Posts: 280
Joined: Wed Dec 31, 1969 5:00 pm

Postby njw » Fri Nov 17, 2006 10:38 am

Ok Steve, I reset styles.css and MainTemplate.html from the original source. The site displayed all the text but wothout any formatting, so I made the following changes to MainTemplate.html:

* Changed all references to $ENV to $_ENV. This got the styles .css working, but lost the horizontal menu and the logo.
* Added reference to archomai_style.css This got the widths almost correct, but that's probably due to me not editing the correct file originally.
* Changed $_ENV back to $ENV for horizontal menu section. Started working.
* Changed $_ENV back to $ENV for logo section. Started working.
* "Sites" section not working - commented out. This displays fine, but errors with call to invalid module, or something similar, when clicked.

So, on the plus side, I have a working site - many thanks for reminding me of first principles!

On the downside, I still don't understand what has caused the problem!

Any further thoughts?

Neil
njw
 
Posts: 280
Joined: Wed Dec 31, 1969 5:00 pm

Previous

Return to LCMS Discussion

Who is online

Users browsing this forum: No registered users and 1 guest

Powered by Dataface
© 2005-2007 Steve Hannah All rights reserved